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Introduction 
This Document 
This document describes the process of installation of Audiobase3 3.5.7 or better on a Windows7 64-
bit SP1 Host PC. For Windows XP 32bit SP3 based installations, contact support@fairlightau.com  

Description 
AudioBase3 features a completely new engine. This engine can be used with MySQL databases and 
Apache2 webservers.  

AudioBase3 integrates with Apple’s iTunes, which provides a robust mechanism for ripping and publishing 
library CDs directly to AudioBase3. It also supports direct scanning and publishing of compatible WAV, AIFF 
and MP3 files, including metadata extraction.  

While AudioBase3 includes an installer, several external components are required. Therefore, please make 
sure ALL installation steps have been completed correctly before attempting to use AudioBase3!  

Apache2 and MySQL is the only supported configuration for AudioBase3. Other webserver/database 
combinations are not supported. Your operating system must be Windows7 Professional 64bit. 

Dream II systems should be running version 3.1.59 or above.  
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PC Configuration and Specifications: 
Audiobase as an application is not a particularly large or processing-intensive application. As such, a 
relatively modest PC with current CPU and RAM compliment should be fine. Audiobase is not 
designed or expected to have to play-back HD video, and therefore does not require a significantly 
large graphics card. 
 
In order to hold the potentially large Sound Effects, Music, and Foley libraries some studios may 
have to handle, a large-capacity media harddrive, physically independent of the Windows System 
drive, is recommended. For those studios who deem it necessary, the Media drive array may be 
configured as a RAID array, with the RAID mode chosen to provide a suitable balance between 
data-protection and sheer-speed performance. 
 
Note: Some facilities have requested the ability to store the Audiobase libraries on a network-shared 
drive. This is technically possible, but requires significant additional installation steps, and a high 
degree of I.T. competence to correctly configure. Using a dedicated local harddrive within the 
Audiobase server machine is much easier for the average End User to install. The following 
procedure assumes the Audiobase machine is equipped with its own internal Media Harddrive. 
 
To facilitate addition of files from optical media such as DVD-Data disks, and ripping of audio CD 
content, a suitable CD/DVD drive is recommended. 
 
As it is envisaged that the Audiobase “server” machine will be accessed via a studio-wide Ethernet 
network, obviously a machine with Gigabit LAN ports is preferable. The architecture of the studio 
network itself will also play a part in the performance of the Audiobase service. Therefore, it is 
highly recommended that the host network be configured for Gigabit-speed operation. 
 
The following is just one example of a cost-effect, workhorse Audiobase server configuration. 
 
Tested Configuration : HP Z400 Workstation 
Processor : Intel Core i7 W3520 2.67 GHz (Quad core) 
BIOS : HP version 3.54 date 21/11/2011 
Memory : 3 GB DDR3 RAM 
Software : Audiobase3 version 3.5.9 
Operating System : Microsoft Windows 7 Professional 64bit SP1 
 
Installed Expansion card 

PCI slot # Slot Type Card Installed 
1 - PCIe 8/4  
2 - PCIe 16 NVidia Q600 (NVidia driver 275.36) 
3 - PCIe 8/4  
4 - PCIe16  
5 - PCI  
6 - PCI  

 
Installed Harddrive Array 
Drive Bay # Size Internal/External Drive Connected to… 

1 5 ¼” External HP CD/DVD SATA 4 
2 5 ¼” External Seagate 7200.12 1TB SATA 1 
3 5 ¼” External  SATA 2 
4 3 ½” Internal  SATA 3 
5 3 ½” Internal 250Gb SATA (HP supply) SATA 0 

 
Harddrive Notes: 

- 1 X Seagate 7200.12 7200rpm 32Mb Cache NCQ drive for Audiobase Library 
- Additional Media drives may be added to gain more capacity, and/or RAIDed together 

for additional data protection 
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Audiobase Pre-Installation Checklist 
- Windows7 Professional 64bit + SP1 installed 
 
- all Microsoft “Critical Updates” applied 
(Do NOT install any “Optional” or “Hardware” updates,  
or any Critical Updates which are NOT automatically selected!) 

- An Administrator-Level profile is available for setup and operation of Audiobase 

- User Access Control (U.A.C.) is disabled 
 
- Media Harddrive is installed and configured 

- Windows Computer Name is _confirmed_ and _known_ 
(Example installation procedure below uses the Computer Name “Audiobase-Server”) 

- IP address of the Audiobase machine is _confirmed_ and _known_ 
(It is recommended to configure the Audiobase machine with a static IP address). 

- Administrator-Level Username and Password is _confirmed_ and _known_ 
(Example installation procedure below uses 
Username  :   AB3Username 
password   :   ab3password  
 
- Local drive letter for Media harddrive is _confirmed_ and _known_ 
(Example installation procedure below uses drive letter “L” for “Library”) 
 
- Windows is configured to Auto-Logon to the Administrator-Level account on start-up  

- “File and Printer Sharing” is _enabled_ in Windows Firewall 

- Power-Handling is set to “High Performance”, and all “sleep”/”hibernate”/”idle” functions have 
been disabled 
 
- Manually create the following folders on the root of the Media Harddrive L:\ 
 - WAV1 
 - WAV2 
 - ML4 
 - iTunes 
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Audiobase3 Software Installation 
Required Files: 
• iTunes64Setup.exe (recommend version 10.4 for 64-bit O/S or better) 
• Apache_2.0.63-win32-x86-no_ssl.msi  
• Mysql-essential-5.0.51b-win32.msi 
• Mysql-gui-tools-5.0-r17-win32.msi 
• SetupAB3-0065-3.5.7.exe or newer  
• ZendOptimizer-3.3.0a-Windows-i386.exe  

(Not Required for 3.5.8 or newer “NoZend” versions) 
 

Installation Procedure:  
*** Please temporarily disable all Firewalls and Security Programs during the installation *** 

1 - Install iTunes  

Double click on <iTunes64Setup.exe>,  

You may be prompted “Do you want to run this file”? 
If so, click “Run” 

 

Follow all prompts for a “default” installation.  

 

Once the installation is completed, click “Finish” 
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1a – Configure iTunes 

Open iTunes, and select “Edit -> Preferences”.  

 

On the “Preferences” pop-up, click the “General” tab, and click the “Import Settings” button 

 

Select ‘Import Using : WAV Encoder’ 
Select ‘Setting : Custom’ 

 

On the “WAV Encoder” pop-up, modify sample rate, bit depth, and channel count as shown 
below. Click “OK” to accept the WAV Encoder changes. 
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Click “OK” to accept the Import Settings changes. 

 

 

 

Select the “Advanced Tab” 
Change the iTunes music folder location to the Audiobase Media Harddrive (eg L:\iTunes).  

     

 

 

Make sure ‘Keep iTunes Music folder organized’ and ‘Copy files to iTunes Media folder when 
adding to library’ is checked.  

 

Click “OK” to exit the “Advanced Preferences” window, and close iTunes  
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1b – Configure iTunes Component Services 

Open ‘START -> Control Panel -> Administrative Tools. 

           

Double-click ‘Component Services’ 

 

Select ‘Computers -> My Computer -> DCOM Config -> iTunes’.  
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Right-click on ‘iTunes’, and select ‘Properties’ 

 

 

Click on the “Identity” tab, and select “the interactive user”.  

 

 

Select ‘Security’ tab.  
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Under ‘Launch and Activation Permissions’, select ‘Customize’.  

Click ‘Edit’.  

 

Click ‘Add’ 

 

In the “Enter the object names to select” field, enter ‘Everyone’.  

Click ‘Ok’.  

 

With ‘Everyone’ selected,  

Check ‘Allow’ next to  
- ‘Local Launch’, 
- ‘Remote Launch’,  
- ‘Local Activation’  
- ‘Remote Activation’. 

Click ‘Ok’.  
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Under ‘Access Permissions’, select ‘Customize’.  

Click ‘Edit’.  

 

Click ‘Add’ 

 

In the “Enter the object names to select” field, enter ‘Everyone’.  

Click ‘Ok’. 

 

With ‘Everyone’ selected,  

check ‘Allow’ next to  
- ‘Local Access’  
- ‘Remote Access’.  

Click ‘Ok’.  
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Under ‘Configuration Permissions’, select ‘Customize’.  

Click ‘Edit’.  

 

 

 

Click ‘Add’  

 

 

 

In the “Enter the object names to select” field, enter ‘Everyone’.  

Click ‘Ok’.  
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With ‘Everyone’ selected,  

check ‘Allow’ next to  
- ‘Full Control’  
- ‘Read’.  

Leave ‘Special Permissions’ at its default state.  

Click ‘Ok’.  

 

 

 

Click “OK” to close “iTunes Properties”.  

 

Please be aware that the Server must be connected to the Internet for iTunes to work.  
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2 - Install Apache2 Server  

This is a freely-available source code implementation of an HTTP (Web) server used by AB3. ** 
Note: AB3 is not yet compatible with Apache 2.2, so make sure to download the latest release 
of Apache 2.0 at http://httpd.apache.org/download.cgi .   

Double-click on <apache_2.0.63-win32-x86-no_ssl.msi>, follow all prompts for a “default” 
installation.   

You may be prompted “Do you want to run this file”? 
If so, click “Run” 

 

 

When prompted,  
- Enter “localhost” for domain name and server name.  
- Enter your “admin” email address.  

Then click “Next” 

 

 

When prompted, select “Typical” setup type, 
and click “Next” 
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When prompted, click “Finish” to complete the Apache Installation. 
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3 - Install MySQL  

Install MySQL as follows:  

Launch <mysql-essential-5.0.51b-win32.msi>  

You may be prompted “Do you want to run this file”? 
If so, click “Run” 

 

Click 'Next' 

 

Select 'Typical' setup type, and click ‘Next’ 

 

Click 'Install'.  
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Leave 'Configure MySQL Server now' checked, and click ‘Finish”  
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3a – Configure MySQL Server 

Click 'Next' in the configuration Wizard.  

 

 

 

Select 'Standard Configuration' and click 'Next'.  

 

 

 

Leave 'Install as Windows Service' and 'Launch the MySQL Server automatically' checked. 

Click 'Next'.  
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Enter a root password.  
Note: USE A STRONG PASSWORD  
(a combination of letters and numbers at least 8 characters long).  

Make sure to WRITE YOUR PASSWORD DOWN, and STORE IT WHERE YOU CAN FIND IT 
LATER!!  

Click 'Next'. 

 

 

 

Click 'Execute' 

 

 

 

Click ‘Finish’ 
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3b – Install MySQL GUI Tools 

Install <mysql-gui-tools-5.0-r17-win32.msi> with the default options.  

You may be prompted “Do you want to run this file”? 
If so, click “Run” 

 

 

When prompted, select “Complete”, and click “Next” 

 

 

When prompted, click “Finish” to complete the MySQL GUI Tools installation. 
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4 – Install Audiobase3   

Install AudioBase3  

Launch <SetupAB3-006x-3.5.x.exe>  

 

 

 

 

Select Database - Choose MySQL.  
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Select Webserver -  Choose Apache  

 

QDC Compatibility  
– If the Audiobase3 installation must support older QDC engines, choose  
“I have QDC or MFX Engines on my Audiobase network” 
(restricts filename characters and length to maintain QDC compatibility, 
disables MP3 compatibility) 

- Otherwise, choose 
“I only have CC-1 Engines on my Audiobase Network”  

 

Enter AudioBase3 Options as required  ( Always use a forward slash / )  
In the example below, the Audiobase Media drive is Local drive L:/ 
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5 - Installing Zend Optimizer  
(NOT Required for Audiobase 3.5.8 or newer “NoZend” versions. 
Go to Step 6) 

Zend optimizer is required to run compiled PHP binaries.  

Launch the Zend Optimizer Installer <ZendOptimizer-3.3.0a-Windows-i386.exe>  

You may be prompted “Do you want to run this file”? 
If so, click “Run” 
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Select the desired webserver, Apache should be automatically detected and selected by default. 
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6 – Run the MySQL Configuration Scripts 

Open 'Start->Programs->MySQL->MySQL Query Browser’.  

 

 

Enter the login information as shown below, including the MySQL root password noted earlier. 

Click “OK” to LogIn  

 

 

If prompted to create a new schema, click “Yes” 

 

 

File > Open Script 
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Select the AB3_MYSQL.sql file found in the \My Documents\AudioBase3 SQL folder, 

And click “Open” 

 

 

Click “Execute” 

 

 

File > Open Script 
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Select the MYSQL_D2.sql file found in the \My Documents\AudioBase3 SQL folder, 

And click “Open” 

 

Click “Execute” 

 

Close Command Line Client.  

Launch Internet Explorer, and enter the address 

http://localhost/audiobase 

You should be greeted with the Audiobase Search page! 
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Configuring DREAM II/Xynergi 
Audiobase drive mapping 
Each Fairlight editing system will need the AudioBase3 Media Harddrive to be mapped as 
generic UNC volume.  

Launch “My Computer” or Windows Explorer,  
select “Computer” at left, and click “Map Network Drive”.  

Select a drive letter for the mapped drive.  

Enter the generic UNC path for the drive under ‘Folder’, eg - \\Audiobase-Server\L$ for drive L 
on the remote server named Audiobase-Server. Make sure to use the Computer Name – not 
the IP address!  

Check ‘Reconnect at logon’. 

Check ‘Connect with different credentials’ 

 

Enter a username (eg – ‘Audiobase-Server\AB3Username’, following the format 
‘computername\username’) and password for an authorized user on the server.  

Check ‘Remember my credentials’.  

Click ‘OK’ 
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Preparing the Audiobase drive for first use 
To prepare the mapped drive for use with DREAM II, 

- Launch Dream/Xynergi 

-  select Setup > Media and Project Management.  

- Select the Mapped Audiobase harddrive from the devices list, 

and click on Convert to Media device.  

- Please also set the Device Info accordingly  

(in most cases, this is set automatically and does not need to be changed).  

If your library drives contain many subfolders, click the “Find Subfolders” button in Setup > 
Media and Project Management.  

Locate the topmost folder in the library folder tree, and click OK. 

All subfolders will now be scanned.  

 



Audiobase3 Win7 Installation Manual CONFIGURING DREAM II/XYNERGI July 31, 2012 

Fairlight Audiobase3 Page 34 
 

Configuring the DreamII/Xynergi Audiobase settings 
Set up your AudioBase3 Server in Setup Æ General Preferences Æ Audiobase  

For Dream II/Xynergi systems V3.2 and earlier 

Example: http://192.168.1.100/AudioBase/MFX/Search_d2.php  
(Where 192.168.2.100 is the IP Address of your AudioBase3 Server)  

- Enter the path in the “Add Address” field 

- Click “Add”  

 
Select the required Preview mode. 

Click “OK’ to accept the configuration. 

 
Restart DreamII/Xynergi, and your Audiobase search functions should now be functional! ☺ 
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For Dream II/Xynergi systems V4.0 and beyond 

Enter the name of the Audiobase machine in the “Add Server Name” field 
Example: Audiobase-Server  
(Where “Audiobase-Server” is the Computer Name of your AudioBase3 machine)  

Click “Add”  

 

Select the required Preview mode. 

Click “OK” to accept the configuration. 

 
Restart DreamII/Xynergi, and your Audiobase search functions should now be functional! 
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Accessing the AudioBase3 Web Interface  
To access AB3 from a “remote” networked PC  

- Launch Internet Explorer 

- Enter http://X.X.X.X/audiobase/ into the address bar 
(where X.X.X.X = the IP address being that of the AudioBase Server)  
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Testing/Troubleshooting  
Initial troubleshooting steps 
1) On the Audiobase server, open your favourite browser, and enter the following address 

http://localhost 

You should see an Apache webserver response page. 
(If NO, check  
- that Apache is installed,  
- and the Apache service is running).  

2) Add “audiobase” to the test address 

http://localhost/audiobase 

You should see the AudioBase3 search page.  
(If NO, check  
- that Audiobase is installed,  
- if required, that ZEND has been installed, see Step 5 above, 
- and that the relevant configuration scripts have been run). 

3) Place a few WAV files in your AudioBase3 ‘WAV1’ and ‘WAV2’ folders. Use the AudioBase3 
web interface to scan the files into AudioBase3. After scanning, you should be able to search 
for the files and play the scanned clips.  

4) On a networked machine or Xynergi editing system capable of seeing the Audiobase server, 
open your favourite browser, and point it to the IP address of the Audiobase server. 

EG: if the Audiobase server IP address is 192.168.3.1, then type 

http://192.168.3.1 

You should see an Apache webserver response page. 
(If NO, check  
- that the Apache service is running on the Audiobase server,  
- and that there are no Firewall, Security, or Permissions issues in effect 
HINT! Set “Incoming Rule” to allow access to Port 80).  

5) Add “audiobase” to the test address 

EG: if the Audiobase server IP address is 192.168.3.1, then type 

http://192.168.3.1/audiobase 

You should see the AudioBase3 search page. You should be able to search for the files and 
play the scanned clips. 

6) On the Xynergi editing system, confirm that the Audiobase Media drive has been mapped 
using UNC paths. 

EG if the Audiobase server PC name is “Audiobase-Server”, 
and the physical drive letter for the Media drive is “L”, 

Then the correct UNC path should be 

\\Audiobase-Server\L$ 

Confirm that this mapping is active and connected 

7) Launch the Xynergi software, and confirm that the Audiobase Media drive is visible within 
Media and Project Management. 
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Confirm that the Audiobase Media drive is set as a “Dream II” device, and is set as either 
“Audio” or “Both”. 

8) On the Xynergi editing system, navigate to 

Setup > General Preferences > Audiobase 

And confirm that the path to the Audiobase server search is correct. 

Common Problems:  
Audiobase Server: 

1) I can’t connect to the database!  

- The FairlightAU user and password may not be set up correctly. Try connecting to your 
database locally using the MySQL query tool and the FairlightAU username and password.  

- If this does not work, try the root/sa username and password.  

- If this does not work, is your database running? 

2) iTunes Publish is not working!  

- Have you set the correct path to the iTunes XML file in config.php?  
- Have you set up iTunes COM in Component Services?  

3) ML4 Publish isn’t working!  

- Does the webserver user account have write permissions to the ML4 folder?  
- Have you refreshed the ML4 folder?  

4) Apache2 won’t start!  

- Is IIS installed and running  
(check Control Panels->Administrative Tools->Internet Information Services)?  
If so, stop IIS.  

- Are other webservers or VOIP programs (eg – Skype) installed?  

Editing Suite: 

1) I can search from Dream II, but I can’t preview or paste files!  

- Have you mapped your server drive(s) and set them as media devices, as described in 
“Configuring Dream II”?  
- Have you selected “Find Subfolders”, as described in“Configuring Dream II”?  
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Technical Assistance  
1) PHP error messages are enabled in AudioBase3. If you encounter an error when using the 

web interface, please copy the request URI (from the url bar) and the error message(s) and 
email them to support@fairlightau.com..  

2) If you are experiencing intermittent errors with Dream II, you may have found a bug. 
Please zip your debug logs and email them to support@fairlightau.com .  

FairlightAU Sept 
2012  

 


